TextEdit

TextEdit lets you create all kinds of text documents. It includes tools to format and layout your page, edit and stylize text, check spelling, create tables and lists, import graphics, work with HTML, and even add music and movie files. Here are some of the things you can do in TextEdit.

TextEdit does more than just let you edit text. Take a look at some of the things you can do to your documents.

Open TextEdit from the Dock, or in the Launchpad (for OS X Lion).

Start typing whatever you want in the window. If you want to change the text alignment from the default left alignment, highlight the text and click one of the four alignment buttons in the toolbar to align left, center, justify, or align right.

TextEdit automatically checks spelling as you type and will underline words that it thinks are misspelled with a red dotted line. If you need help with the correct spelling, highlight the word and from the Edit menu, choose Spelling and Grammar, then Show Spelling and Grammar from the submenu to open the Spelling window. The window displays its best guesses for what you were trying to spell. To correct your mistake, select the correct word and click Correct. TextEdit will also automatically correct your spelling as you type or present you with spelling options for the word you are trying to spell.

TextEdit has a built-in spell check and will automatically correct your spelling as you type.

To change the font, from the Format menu, choose Font > Show Fonts. In the resulting Font window, select a font typeface and size from the columns. You can also choose to add an underline, add a strike-through, change the text color, and add a text shadow from the pop-up menus at the top of the Font window.

To add a photo, music, or movie file, just drag the file from a Finder window to the document.

To create a list, choose a list style from the list pop-up menu. You can pick options like bullets, numbers, or lettered lists.

Begin typing your list. To end your list, choose None from the list pop-up menu.

Instead of manually entering bullet points, numbers, or letters, use the Lists pop-up menu to have TextEdit create the list formatting for you

To create a table, from the Format menu, choose Table. In the resulting Table window, enter the number of rows and columns you want, select the text alignment, choose the cell border thickness and color, and choose a background color. Your TextEdit document updates as you make changes.