Using iMovie:

Customizing:

Using analog/FireWire converter devices with iMovie:

You can convert video in 8 mm, Hi8, VHS, or SVHS format to digital video (DV) format, using a special converter box (sometimes referred to as AV adapters), such as the Sony DVMC-DA2 or the Synchrotech Formac Studio.
If you use a converter to import non-DV video, you can’t control your camera or deck with iMovie. However, you can manually control the camera to import video clips and use all of iMovie’s editing features, then export your video through the converter back to your video recorder or camera.

A converter of this kind will generally have standard S-video and RCA input/output ports for video and audio, and a FireWire or iLink (IEEE 1394) input/output port. Make sure you have the appropriate cables for your configuration.

To ensure compatibility with third-party video devices, check the iLife Camcorder Compatibility page, the Apple Store, and/or vendor websites for compatibility information.

For more information, check the documentation that came with your converter.

Capturing Analog Video From a Converter Box Into iMovie:

Follow these steps to import video from an analog-to-FireWire converter device.
While this specific order may not be necessary with all converters, it will help ensure proper initialization between the hardware and software:

  1. Start up your computer, turn on the converter box, and connect the computer to the converter with a FireWire cable.
  2. Connect the video cable from the video output of the video source (for example, a VCR or video camera) to the analog video input of the converter box. A video camera should be in playback or VTR mode. Connect the audio source, too.
  3. The converter box will typically have a switch or button that tells the device which direction to convert the video, analog to DV or DV to analog. For capturing analog video, you will want to press the button labeled “Analog In” or something similar.
  4. Connect a 4-to-6 pin FireWire cable from the DV out port on the converter box (sometimes labeled FireWire, IEEE 1394, or iLink with Sony devices) to a FireWire port on the computer.
  5. Open the iMovie application program.
  6. Make sure the Mode Switch under the iMovie monitor is set to Camera Mode, as shown here:
  7. Some converter boxes have a green status light, to indicate a good connection. If this light is amber or red at this point, try turning the device off for several seconds and then back on again. You may also try quitting and opening iMovie again.
  8. Press play on the VCR or analog camera. You should see the video signal in the iMovie monitor. If you have speakers or headphones connected to the VCR you can monitor the audio.
  9. Use the controls on the video source to manually cue the video tape to the desired spot, and click Import in iMovie. iMovie will create a new clip for about every nine minutes of video. You can join all the clips later by dragging them into the timeline.

Sending Video From iMovie to the Converter Box:

Follow these steps to export video to an analog-to-FireWire converter box.
While this specific order may not be necessary with all converters, it will help ensure proper initialization between the hardware and software:

  1. Start up your computer, turn on the converter box, and connect the computer to the converter with a FireWire cable.
  2. Connect the video cable from the video output of the source (for example, a VCR or video camera) to the analog video input of the converter box. A video camera should be in playback or VTR mode. Connect the audio source, too.
  3. The converter box will typically have a switch or button which tells the device which direction to convert the video, analog to DV or DV to analog. For exporting analog video, you will want to press the button labeled “Analog In” or something similar.
  4. Connect a 4-to-6 pin FireWire cable from the DV out port on the converter box (sometimes labeled FireWire, IEEE 1394, or iLink with Sony devices) to a FireWire port on the computer.
  5. Open the iMovie application program.
  6. From the iMovie menu, choose Preferences (or File menu in Mac OS 9).
  7. Click the Advanced tab.
  8. Make sure the checkbox for “Video Play Through to Camera” is selected.
  9. Choose Export Movie from the File menu, or press Command-E on the keyboard.
  10. In the Export Movie window, select the pop-up menu for “Export to Camera”, even if you’re exporting to a VCR through the converter.
  11. Press record on the VCR and click Export in iMovie.
  12. When finished, press the stop button on the VCR and Stop in the iMovie monitor.


Publishing:

Publishing directly to YouTube:

You can publish your iMovie project directly to the YouTube website. YouTube is an independent website that freely hosts videos by its community members. To post to YouTube, you must have a YouTube account.

To publish to YouTube:

  • Select your project in the Project Library, and then choose Share > YouTube.
  • Choose your account in the Account pop-up menu.
  • If you don’t have a YouTube account, click Add to be guided through the account creation process on the YouTube website.
  • Choose a category from the pop-up menu for the video to be categorized on the YouTube website.
  • Fill in the following fields:
  • Title: The name of your movie.
  • Description: Some information about your movie for viewers to read.
  • Tags: Keywords that viewers can use to search for and find your movie.
  • Select the mobile or medium size for your movie.

If the larger sizes are not available, the original project media isn’t large enough to render in that size. The largest media size used in the project determines the final movie sizes you can render.

The dots below each device in the table of sizes indicate which movie sizes are recommended for use with that device. Either size is good for streaming from the YouTube website; the mobile size will be easier to watch for people with slower internet connections.
Hovering the pointer over the “i” next to the movie dimensions displays the following information for the rendered movies:

  • H.264: The standard video compression that’s used in the movie.
  • fps: The frame rate of the movie in frames per second.
  • Kbps: The maximum rate at which the movie can be streamed over the Internet in kilobytes per second.
  • MB: The size of the movie file in megabytes.
  • You can limit who can view the movie by making selecting “Make this movie private.”
  • Click Publish. iMovie automatically uploads your movie to the YouTube website.
  • After the movie has been uploaded to YouTube, the title bar of your project in iMovie displays “Published to YouTube.” It also displays buttons that take you to the movie’s webpage and send notifications to your friends.
  • To visit your movie’s webpage, click Visit.
  • To notify your friends of the new movie you’ve published, click “Tell a friend.”

If you make further edits to your project in iMovie after you’ve published it to YouTube, the title bar indicates that your project is out of date and needs to be rendered again. Old versions of the movie are deleted and replaced by new ones when you render it again.

If you want to save the previous version of your movie before you edit it, you can do so by exporting it to the Finder.

Publishing directly to your .Mac Web Gallery:

To share your movies over the Internet, you can publish your iMovie projects directly to your .Mac Web Gallery. After you publish a movie, send its internet address to your friends and family so they can view it.

To publish to your .Mac Web Gallery, you must have an active .Mac account. If you don’t already have a .Mac account, you can sign up for one at the .Mac or MobileMe website.

To publish to your .Mac Web Gallery:

Select your project in the Project Library, and then choose Share > .Mac Web Gallery.

In the “Publish to .Mac” window, fill in the fields:

  • Title: The title of your movie.
  • Description: Some information about your movie for viewers to read.
  • Select one or more movie sizes to publish. The dimensions of the finished movies are shown on the right side of the table.
  • Mobile size is recommended for most purposes; the larger sizes may be difficult to watch for people who have slow Internet connections.

If the larger sizes are unavailable, the original project media isn’t large enough to render in that size. The largest media size used in the project determines the final movie sizes you can render.

Hovering the pointer over the “i” next to the movie dimensions displays the following information for the rendered movies:

  • H.264: The standard video compression used in the movie.
  • fps: The frame rate of the movie in frames per second.
  • Kbps: The maximum rate at which the movie can be streamed over the Internet in kilobytes per second.
  • MB: The file size of the movie in megabytes.
  • Choose an option from the “Viewable by” pop-up menu to set password protection for your movie, depending on whether you want it to be publicly viewable or accessible by only specific people.
  • Everyone: Makes the movie publicly accessible by any visitor to your .Mac Web Gallery.
  • Only me: Requires your .Mac user name and password in order for you to see the movie. Sharing your user name and password with others is not recommended.
  • Edit names and passwords: Allows you to create user names and passwords that you can provide to others whom you want to be able to access the movie. After selecting this option, click the Add (+) button in the bottom-left corner of the window and then type a user name. Press the Tab key, and then type the password you want to associate with the user name. User names and passwords must be between four and twenty characters long and can include only letters (a through z), digits (0 through 9), the underscore (_) or a period (.), but not more than a single period can be used at the end. Any Web Gallery movies available to this user will be listed to the right of the password. Click OK, and then select the user name from the “Viewable by” pop-up menu.
  • Select “Hide movie on Web Gallery homepage” if you do not want the movie to appear on the homepage of your .Mac Web Gallery.
  • Select “Allow movie to be downloaded” if you want viewers to be able to download copies of your movie.
  • Click Publish. iMovie automatically uploads your movie to your .Mac Web Gallery. After the movie has been uploaded to .Mac, the title bar of your project in iMovie displays “Published to .Mac.” It also displays buttons that take you to the movie’s webpage and send notifications to your friends and family.
  • To visit your movie’s webpage, click Visit.
  • To notify your friends and family of the new movie you’ve published, click “Tell a friend.”
  • If you want to remove your movie from .Mac, choose Share > “Remove from .Mac.”

If you make further edits to your project in iMovie after you’ve published it to .Mac, the title bar indicates that your project is out of date and needs to be rendered again. The old version of the movie is deleted and replaced by the new one when you publish it again by choosing Edit > “Republish to .Mac Web Gallery.”

If you want to save the previous version of your movie before you edit it, you can do so by exporting it to a folder in the Finder.


Watching:


Watching your movies on Apple TV:

If you want to view one of your iMovie projects on your Apple TV, you need to send it to iTunes. When you send your project to iTunes, iMovie allows you to create one or more movies of different sizes, depending on the size of the original media that’s in your project. The large size movie is best for viewing on Apple TV.

To send your project to iTunes:

  • Select it in the Project Library, and then choose Share > “Share Project with iTunes.”
  • Select one or more sizes of movie to render. If the larger sizes are not available, the original project media isn’t large enough to render in that size. The largest media size used in the project determines the final movie sizes you can render. The dots below each device in the table of sizes indicate which movie sizes are recommended for use with that device. Hovering the pointer over the “i” next to the movie dimensions displays the following information for the rendered movies:
  • H.264: The standard video compression that’s used in the movie.
  • fps: The frame rate of the movie in frames per second.
  • Kbps: The maximum rate at which the movie can be streamed over the Internet in kilobytes per second.
  • MB: The files size of the movie in megabytes.
  • Click Publish. Rendering can take up to several minutes depending on the size of your movie and if you’re rendering several sizes at once. After the project has finished rendering, iTunes opens automatically.
  • In iTunes, click Movies to see your movie and broadcast it through Apple TV.

In iMovie, an icon appears next to the project’s name in the Project Library to indicate that the project has been rendered. If you select the project in the Project Library, its title bar indicates that it’s been sent to iTunes.

If you make further edits to your project in iMovie after you’ve sent it to iTunes, the title bar indicates that your project is out of date and needs to be rendered again. Old versions of the movie are deleted and replaced by new ones when you render it again.

If you want to save the previous version of your movie before you edit it, you can do so by exporting it to the Finder.

Watching your movies on your iPod:

If you want to view one of your iMovie projects on your iPod (or download it to you iPhone), you need to send it to iTunes. When you send your project to iTunes, iMovie allows you to create one or more movies of different sizes, depending on the size of the original media that’s in your project. The medium sized movie is best for viewing on your iPod.

To send your project to iTunes:

  • Select it in the Project Library, and then choose Share > “Share Project with iTunes.”
  • Select one or more sizes of movie to render.
  • If the larger sizes are not available, the original project media isn’t large enough to render in that size. The largest media size used in the project determines the final movie sizes you can render.
  • The dots below each device in the table of sizes indicate which movie sizes are recommended for use with that device. Hovering the pointer over the “i” next to the movie dimensions displays the following information for the rendered movies.
  • H.264: The standard video compression that’s used in the movie.
  • fps: The frame rate of the movie in frames per second.
  • Kbps: The maximum rate at which the movie can be streamed over the Internet in kilobytes per second.
  • MB: The files size of the movie in megabytes.
  • Click Publish. Rendering can take up to several minutes depending on the size of your movie and if you’re rendering several sizes at once. After the project has finished rendering, iTunes opens automatically.
  • In iTunes, click Movies to see your movie and download it to your iPod or iPhone.

In iMovie, an icon appears next to the project’s name in the Project Library to indicate that the project has been rendered. If you select the project in the Project Library, its title bar indicates that it’s been sent to iTunes.

If you make further edits to your project in iMovie after you’ve sent it to iTunes, the title bar indicates that your project is out of date and needs to be rendered again. Old versions of the movie are deleted and replaced by new ones when you render it again.

If you want to save the previous version of your movie before you edit it, you can do so by exporting it to the Finder.

Watching your video on your iPhone:

There are two ways to view an iMovie project on your iPhone:

  • Send it to iTunes and download it just as you do for an iPod.
  • Publish it to your .Mac Web Gallery.

To learn how to send a movie to iTunes for downloading to your iPhone, see the instructions for watching your movie on your iPod.

Watching your movies on your iPod:

To publish to .Mac, you must have an active .Mac account. If you don’t already have a .Mac account, you can sign up for one at the .Mac website.

To publish your video to the .Mac Web Gallery and watch it on your iPhone:

  1. Select your project in the Project Library, and then choose Share > .Mac Web Gallery.
  2. In the Publish to .Mac window, fill in the fields: Page Title: The title of your movie. Description: Some information about your movie for viewers to read.
  3. Select the tiny and mobile sizes to publish. Your iPhone uses either of these sizes, depending on how you’re connected.
  4. Select “Allow movies to be downloaded” if you want viewers to be able to download copies of your movie.
  5. You can limit who can view the movie by selecting “Show project on Web Gallery home page.”
  6. Click Publish. iMovie automatically uploads your movie to your .Mac Web Gallery. After the movie has been uploaded to .Mac, the title bar of your project in iMovie displays “Published to .Mac.” It also displays buttons that take you to the movie’s webpage and send notifications to your friends and family.
  7. To find out the URL (web address) for the movies published to your .Mac Web Gallery, click Visit, and then write down the URL.
  8. Using Safari on your iPhone, navigate to the URL for your movies.

In iMovie, an icon appears next to the project’s name in the Project Library to indicate that the project has been rendered. If you select the project in the Project Library, its title bar indicates that it’s been sent to your .Mac Web Gallery.

If you make further edits to your project in iMovie after you’ve published it to .Mac, the title bar indicates that your project is out of date and needs to be rendered again. The old version of the movie is deleted and replaced by new ones when you publish it again by choosing Edit > “Republish to .Mac Web Gallery.”

If you want to save the previous version of your movie before you edit it, you can do so by exporting it to the Finder.

Watching your movies in Front Row:

If you want to view one of your iMovie projects in Front Row, you need to send it to iTunes. When you send your project to iTunes, iMovie allows you to create one or more movies of different sizes, depending on the size of the original media that’s in your project. You’ll be able to play any of these sizes in Front Row.

To send your project to iTunes:

  • Select it in the Project Library, and then choose Share > iTunes.
  • Select one or more sizes of movie to render.

If the larger sizes are not available, the original project media isn’t large enough to render in that size. The largest media size used in the project determines the final movie sizes you can render.

The dots below each device in the table of sizes indicate which movie sizes are recommended for use with that device. Hovering the pointer over the “i” next to the movie dimensions displays the following information for the rendered movies:

  • H.264: The standard video compression that’s used in the movie.
  • fps: The frame rate of the movie in frames per second.
  • Kbps: The maximum rate at which the movie can be streamed over the Internet in kilobytes per second.
  • MB: The files size of the movie in megabytes.
  • Click Publish. Rendering can take up to several minutes depending on the size of your movie and if you’re rendering several sizes at once. After the project has finished rendering, iTunes opens automatically.
  • In Front Row, select Videos, and then select Movies to find the movies you created in iMovie.

In iMovie, an icon appears next to the project’s name in the Project Library to indicate that the project has been rendered. If you select the project in the Project Library, its title bar indicates that it’s been sent to iTunes.

If you make further edits to your project in iMovie after you’ve sent it to iTunes, the title bar indicates that your project is out of date and needs to be rendered again. Old versions of the movie are deleted and replaced by new ones when you render it again.

If you want to save the previous version of your movie before you edit it, you can do so by exporting it to the Finder.

Exporting:

Export Settings:

You can customize the export settings when you export a movie to QuickTime.

To customize these settings:

  1. Choose File > Export.
  2. Choose Expert Settings from the Formats pop-up menu.
  3. Click the Export button.
  4. Choose Movie to QuickTime Movie from the Export pop-up menu.
  5. Click the Options button.
  6. Click the Settings button in the Video panel to see the compression, frames per second (frame rate), and key frame settings.
  7. Click the Size button in the Video panel to customize the frame size.

In general, choose settings that give you the best trade-off between file size and video playback quality. Before you use the Expert Settings option, consider the following:

Codec options:

  • MPEG-4 is the standard codec (compressor/decompressor) used for Internet movies. To get the MPEG-4 codec option, you must have QuickTime 6 or later.
  • For movies that will be viewed on earlier computer systems, you may want to use the Motion JPEG codec.
  • The Sorensen codec is good for viewing movies on later systems. For earlier systems, use Cinepak or Motion JPEG.

Frame size, Keyframes, and Frame rate:

  1. Pick a movie frame size first. Primarily, frame size determines the movie’s file size.
  2. Set the number of key frames next. If the number of key frames is high, the movie will play back at higher quality, but the file size will be larger. With lower keyframe numbers, the video quality may be lower, but the file size will be smaller.
  3. Set the frame rate last. You may get choppy video playback if you set the frame rate to less than 12 frames per second. But higher frame rates create larger file sizes.

Exporting a movie from iMovie HD to iPod:

Want to put your own movies on your iPod? You can with iMovie HD and an iPod with video compatibility (currently Fifth Generation iPod). You also need to have QuickTime 7.0.3 or later and iTunes 6 or later installed—they’re both free downloads! If you’re not sure what iPod model you have, click here.

  • Find out which version of QuickTime you have here or download the latest version from here.
  • Find out which version of iTunes you have here or download the latest version from here.
  • You can also download and install the latest iMovie, QuickTime, and iTunes updates using Software Update.

To export a movie from iMovie HD 6 to your iPod:

  1. In iMovie HD 6, open the movie you want to transfer.
  2. If you only want to transfer a portion of your movie, select the clips you want to transfer in the timeline viewer.
  3. From the Share menu, choose iPod.
  4. Click to select the “Share selected clips only” checkbox if you only want to share clips you selected.
  5. Click Share.
  6. iMovie HD compresses your movie and saves it to your iTunes library. The time it takes to save the movie depends on the movie’s length.
  7. Open iTunes 6.0 or later, and then sync with your iPod.
  8. For more information about syncing, see the documentation that came with your video-compatible iPod.

To export a movie from iMovie HD 5 to your iPod:

  • Open iMovie HD and create a movie, or open an existing movie in the application.
  • From the File menu, choose Share.
  • Click the QuickTime tab.
  • From the Compress movie for pop-up menu, choose Expert Settings.

  • Click Share.
  • From the Export pop-up menu in the resulting dialog, choose Movie to iPod (320X240).

  • Click Save to start the export process. Depending on the length of your movie, this can take a long time. iMovie uses H.264 compression to create the movie file (video iPod format), which will appear on your hard disk in the location you saved it when iMovie is done. Open the new file in QuickTime Player and play it to make sure it looks as you expect.

  • Open iTunes 6 and drag your new movie file icon to the iTunes library in the Source list. To learn how to browse and view videos in iTunes, click here. Note: iTunes won’t let you drag the movie to the Video playlist, but once you drag it to the Library, it will automatically appear in the Video playlist. You can also drag the video file to a playlist you create or directly to the iPod in the Source list.

  • To copy the movie onto a Fifth Generation iPod, either sync it with your iPod or manually copy it. To learn how to sync video to your iPod click here, check out the iPod tutorial, or check the Features Guide that came with your iPod.

Additional Information:

A note about copyright: This software may be used to reproduce materials. It is licensed to you only for reproduction of non-copyrighted materials, materials in which you own the copyright, or materials you are authorized or legally permitted to reproduce. If you are uncertain about your right to copy any material, you should contact your legal advisor.

Exporting your movie for viewing in PAL or NTSC format:

When you first create a new project in iMovie HD, you can select a video format for the project. The video and images you later add to the iMovie are converted to this format. However, if you need to format your movie to be viewed on a VCR or DVD player that uses another format, you can use the expert export options to convert your movie.

NTSC is a format commonly used in North America and Japan. PAL is a format commonly used by devices in Europe. There are also different versions of these two formats, such as DVCPRO-PAL and DVCPRO50-NTSC, so determine the precise format you need before exporting.

To export a movie in NTSC or PAL format:

  1. Choose Share > QuickTime.
  2. Choose Expert Settings from the “Compress movie for” pop-up menu, and then click Share.
  3. Type a name for your movie and choose where you want to save it.
  4. Choose “Movie to QuickTime Movie” from the Export pop-up menu, and then click Options.
  5. In the Video pane, click Settings to open the Compression Settings dialog.
  6. Choose a format from the pop-up menu (DV-PAL or DVCPRO-PAL for Europe, DV-NTSC or DVCPRO-NTSC for North America and Japan).
  7. Choose a value from the Frames Rate pop-up menu (25 for PAL and 29.97 for NTSC)
  8. Drag the Quality slider to the desired quality. Best is recommended.
  9. Click OK.
  10. Click Size to open the Export Size Settings dialog, and then click “Use custom size.”
  11. Type a value in the Width field (720 for both PAL and NTSC) and in the Height field (576 for PAL and 480 for NTSC), and then click OK.
  12. Click Settings in the Sound pane.
  13. Choose Stereo (L R) from the Channels pop-up menu in the Sound Settings dialog.
  14. Choose 48.000 from the kHz pop-up menu (or type it in the Rate field).
  15. Choose 16 from the “Sample size” pop-up menu, and then click OK.
  16. Click OK in the Movie Settings dialog.
  17. Click Save.

Exporting movies with expert settings:

The export options provided in iMovie HD will work in most cases if you plan to use a QuickTime format. If you want to use a different format, such as MPEG-4, and have some experience with custom settings, you can create your own export settings.

For example, if you want to share your movie with someone who uses an older Windows computer, you can export your movie as an image sequence, then choose the JPEG option.

iMovie HD supports exporting in the following file formats:

  1. 3G
  2. AVI
  3. BMP
  4. DV Stream
  5. FLC
  6. Hinted Movie
  7. Image Sequence
  8. MPEG-4
  9. Picture
  10. QuickTime Movie
  11. Sound to AIFF
  12. Sound to System 7 Sound
  13. Sound to Wave
  14. Sound to uLaw

iMovie also supports many video, audio, streaming, and compatibility options associated with the compression of these file formats. For example, when saving your movie as a QuickTime movie, you can choose among video compression formats such as Cinepak, DV-PAL, DV/DVCPRO -NTSC, JPEG 2000, MPEG-4 Video, Planar RGB, PNG, Sorenson Video, TGA, and more.

iMovie also supports many sound compression formats, such as 24-bit Integer, 32-bit Integer, 64-bit integer, Alaw 2:1, AMR NarrowBand, IMA 4:1, MACE 3:1, Qualcomm PureVoice, and many more.

So if you’re fairly expert at understanding video file formats and compression characteristics, use the expert settings to set up your files the way you want.

To export your movie with expert settings:

  1. Choose File > Export.
  2. Choose Expert Settings from the “Compress movie for” pop-up menu, and then click Share.
  3. Choose the type of export format you want, and then click Options.
  4. Set the compression format (known as a “codec”). Sorenson Video, DV-PAL, and Motion JPEG A are examples of codecs. Depending on the type of export you choose (such as “Sound to AIFF” or “MPEG-4”), you see different codecs and compression options.
  5. Set the frame size. This setting affects the overall file size of your movie. Better quality creates a larger file size.
  6. Set the key frame number. A low number (such as every ten frames) creates a better-quality movie with a larger file size.
  7. Set the frame rate last. You may get choppy-looking video playback if you set the frame rate to less than about 12 frames per second.

Exporting a movie to iDVD:

Once your movie is ready for viewing, iMovie HD can automatically export it to an iDVD project that you can burn on a DVD. You can then view your DVD on a television using a DVD player or on your computer screen using the Apple DVD Player.

Note: Before you export your movie to iDVD, you can add chapter markers to it so that viewers can quickly review different sections of the movie on DVD. If you’ve added chapter markers, they are exported with your movie, and you can use them to add scene selection menus to your iDVD project.

Not all computers support iDVD. See your computer’s manual to find out if your computer does.

To export your movie to iDVD:

  1. Choose Share > iDVD.
  2. Click the “Share selected clips only” checkbox if you only want to share clips you selected.
  3. Click Share.

iDVD opens and your movie appears in a new project in iDVD.

For more information about using iDVD, choose Help > iDVD Help when iDVD is open.

Tip: You can automatically export video to iDVD from your camcorder using the Magic iMovie feature.

Exporting your movie for viewing on Apple TV:

You can watch your movie on Apple TV by exporting it from iMovie HD to your iTunes library, and then using iTunes to stream the movie to Apple TV or sync your Apple TV with your iTunes library.

IMPORTANT: To export a movie for viewing on Apple TV, you must have QuickTime 7.1.5 or later and iTunes 7.1 or later installed on your computer. For the latest versions of these applications, open System Preferences, click Software Update, and then click Check Now.

Before following these instructions, make sure you set up Apple TV for streaming or syncing video. For more information, see the documentation that came with Apple TV.

If you export a movie for viewing on Apple TV, you won’t be able to watch it on an iPod. To learn how to transfer your movie to an iPod, see Related Topics below.

To export your movie for viewing on Apple TV:

  1. In iMovie HD, open the movie you want to export.
  2. Choose Share > QuickTime.
  3. Choose Expert Settings from the “Compress movie for” pop-up menu.
  4. Click Share.
  5. In the “Save exported file as” window, choose “Movie to Apple TV” from the Export pop-up menu.
  6. Choose a location for the movie you’re exporting from the Where pop-up menu, and then click Save.
  7. Open iTunes.
  8. Drag your exported movie to the iTunes Movies library.
  9. Use Apple TV to view your movie.

For more information, see iTunes Help or the documentation that came with Apple TV.

IMPORTANT: Do not delete the exported file from the location you chose in step 6 unless you have iTunes set up to copy files to the iTunes Music folder when you add them to iTunes. To see if this option is turned on, open iTunes, choose iTunes > Preferences, click Advanced, and then click the General tab. If the “Copy files to iTunes Music folder when adding to library” checkbox is selected, you can delete the exported file from the location you chose in step 6.

Customizing your QuickTime export:

If you want to set your own QuickTime settings for your exported iMovie projects, use the QuickTime expert export settings.

To use the expert QuickTime settings:

  1. Select your project in the Project Library and choose Share > Export Using QuickTime.
  2. Type a name for the movie in the Save As field and choose a location to save the file from the Where pop-up menu.
  3. Make your selections for format, compression, and other variables, and then click Save.

Exporting your movies to a Finder folder:

When you share your project with iTunes or the Media Browser, iMovie renders it and makes the rendered versions accessible only through iTunes or the iLife Media Browser.

If you make further edits to your project after you’ve prepared it for sharing or sent it to iTunes, the title bar indicates that your project is out of date and needs to be rendered again. Old versions of the movie in the iTunes or the iLife Media Browser are deleted and replaced by new ones when you render it again.

If you want to save the current version of your movie before you edit it, or if you simply want to create a copy you can access on your desktop or any Finder folder, you need to export it as a movie. Exported movies are identical to the movies that are rendered when you share with iTunes or the Media Browser, but they are accessible through the Finder and can be used by any application that doesn’t have access to movies in iTunes or the Media Browser, such as Mail.

When you export your movie, iMovie gives you four size options:

  • Tiny: Always 176 by 144 pixels.
  • Mobile: Always 480 by 272 pixels.
  • Medium: Varies in size from 640 by 480 pixels (standard aspect ratio) to 640 by 360 pixels (widescreen), depending on the size of the media in your project.
  • Large: Always 960 by 540 pixels (widescreen). No large size is rendered if your original video isn’t high definition (HD).

If the larger sizes are not available, the original project media isn’t large enough to render in that size. The largest media size used in the project determines the final movie sizes you can render.

The dots below each device in the table of sizes indicate which movie sizes are recommended for use with that device.

Hovering the pointer over the “i” next to the movie dimensions displays the following information for the rendered movies:

  • H.264: The standard video compression that’s used in the movie.
  • fps: The frame rate of the movie in frames per second.
  • Kbps: The maximum rate at which the movie can be streamed over the Internet in kilobytes per second.
  • MB: The size of the movie file in megabytes.

To export your project to the Finder:

  1. Choose Share > “Export Movie.”
  2. Type a name for the movie in the Export As field, and then choose the location where you want to save it in the Where pop-up menu.
  3. Select the size that best matches what you’ll be using the video for.
  4. Click Export.
  5. To find your exported movie, navigate to the folder that you chose in the Where pop-up menu.

Exporting a presentation from Keynote to iMovie:

With Keynote you can export your presentation to a number of file formats.

Follow these steps to create a file that you can use in iMovie:

  1. Open your presentation in Keynote
  2. Choose File > Export.
  3. Select QuickTime as the file format.
  4. Select “Fixed Timing” for playback. Do not select the manual advance option; the resulting file may not import into iMovie.
  5. Select “Full Quality Large” for the format setting.
  6. Click Next.
  7. Name and save your movie.

Follow these steps to import this file into iMovie:

  1. Open iMovie
  2. Choose File > Import Movies.
  3. Locate your movie, saved in step 7 above.
  4. Click Import.

Tip: You can also export your presentation from Keynote to other iLife applications by selecting File > Send To… in Keynote.

…more iMovie Tips ?