Adding

Add a Movie and Scene Selection Menu:

After you choose your theme, you can add movies and other content to your iDVD project.
In this step, you’ll add a movie that contains chapter markers, so that viewers have the option of jumping to a scene when they watch your DVD, just like a Hollywood-style DVD.

When you drag a movie with chapter markers to a menu, iDVD recognizes the chapter markers and automatically creates “scene selection menus” with buttons that link to each of the chapters.

To add a movie with chapter markers:

1. Click the Media button.

2. Click the Movies button at the top of the Media pane, shown below.

3. Select the Movies folder.
Thumbnail pictures of the movies in the folder are shown in the bottom part of the pane.

4. Drag a movie with chapter markers from the movies list to the menu background on the left side of the iDVD window.

In the Fish One menu, the menu background is everything you see in the menu: the picture frame, gravel, and fish movie.

Important: If dotted lines appear in the picture frame when you drag your movie, move the mouse pointer until the dotted lines disappear and then drop the movie.
Dotted lines indicate a drop zone, a special area of a menu.
Movies added to a drop zone become part of the menu background, rather than featured movies on the DVD.

When you add a movie with chapter markers, the DVD menu title changes to the name of the movie and iDVD automatically creates two buttons on the menu.

In the illustration above, you see a Play Movie button, so the viewer can play the entire movie, and a Scene Selection button that links to the scene selection menu.

For movies with no chapter markers, the title does not change, and only one button appears, labeled with the name of the movie you added. The drop zone contains the text “Drop Zone 1.”

You can easily change the title and the text on the buttons. In this example, you’ll change the title to “Vacations.”

To change the title text:

  • Double-click the title and type Vacations in its place.

The scene selection menu is a submenu with a button on the main menu that links to it.

  • Double-click the button now to take a look at it.
  • Notice that the menu used the theme Fish Two, which was designed to be used as a chapter menu for the Fish One theme.

Each button on the scene selection menu shown below has an image that matches a frame in the scene it links to.

Each submenu contains a Back button (it looks like an arrow in the illustration above), to indicate where the viewer is in the hierarchy of menus.

If your movie has more chapters than can fit on a single scene selection menu, you will also see a Forward button so viewers can navigate to the next scene selection menu.

  • You can edit submenus just as you can the main menu.

For example, you may want to change the text on the button labels to make it fit better.

  • You change button label text just like you changed the text in the main menu title.

Manually Adding a New Submenu:

A menu can only hold up to 12 buttons, so if your DVD requires more than 12 buttons, you can create submenus to hold them. You can also use submenus to organize your DVD into sections.

For example, if you want viewers to be able to view scenes, extras, and additional movies or slideshows, you can create submenus to hold buttons that link to them.

To add a submenu:

  • Make sure the menu where you want to add a submenu is showing, then click the Add button (shown below) and choose Add Submenu from the pop-up menu.
  • A button labeled “My Submenu” appears.

The new submenu will have the same theme as the menu it links from.

You can keep the theme, customize it, or choose another theme.

Add a Slideshow:

A slideshow is a great way to show your photographs.

You can use a slideshow you created in iPhoto, or you can use iDVD to create a slideshow from a group of pictures.

In this step, you’ll create a slideshow of photographs in iDVD and add a soundtrack.

To create a slideshow in iDVD:

1. If the main menu is not showing, click the Back button (the arrow on the menu) to return to the main menu.

2. Click the Add button at the bottom of the iDVD window and choose Add Slideshow from the pop-up menu.

  • A button named “My Slideshow” appears on the menu.
  • Your menu should now look like the illustration below.

3. Click My Slideshow to select it, then type More Photos.

4. Click outside the text area to deselect the text, then double-click the My Slideshow button to open the slideshow editor.

  • The slideshow editor, shown below, is a blank screen with the words “Drag images here.”
  • If you don’t see this view, try double-clicking again, either slower or faster than the first time.

5. Click the Media button to open the Media pane, then click the Photos button at the top of the Media pane.

Note: If you have not imported photos into iPhoto, you will not see photos in this list.
You can open iPhoto now and import some photos (to see the images in the Photos pane, switch to another view of the Media pane view and then switch back to Photos) or you can drag photos directly from other locations on your hard disk to the slideshow editor.

6. Drag photos one at a time or in groups from the images list to the slideshow editor.
You can even drag a whole album to the slideshow editor.

7. Arrange the images in the order you want them to appear.
Drag the images in the slideshow editor to arrange them.
To delete images, select the ones you want to remove and press the Delete key on your keyboard.

8. Add a transition so the images in your slideshow flow smoothly from one to the next.
Click the Transition pop-up menu and experiment with the transitions in the menu until you find one you want to use.

9. Click Settings, shown above, and make any other creative decisions you like using the other settings in the slideshow editor.

  • To make the slideshow repeat continuously, select “Loop slideshow.”
  • To show navigation arrows on the slideshow, select “Display navigation arrows.”
  • To add copies of the original slides to the DVD-ROM portion of the disc, select “Add
  • image files to DVD-ROM.”
  • To hide the title and comments text below the images, deselect “Show titles and comments.” It’s OK to leave these on even if you don’t add titles or comments below your images. Only what you type will be visible in your slideshow.

10. Click the Audio button at the top of the Media pane to add a soundtrack for your slideshow.

The contents of your iTunes library and any music you composed in GarageBand are shown in the audio list.

If you don’t see any music in the audio list, make sure you have imported music into iTunes.

Tip: You can type the name of a song in the search box to quickly locate a particular song.
Click the Play button at the bottom of the Media pane to listen to a song before you add it to your DVD
.

11. When you see a song that you want to use, drag it from the song list into the audio well in the slideshow editor, shown below.

After you drag the song to the audio well, notice that the Slide Duration pop-up menu automatically changes to “Fit To Audio.”
This way, your slideshow and music begin and end together. You can change this if you want.

12. Click the Preview button, shown below, to see how your slideshow looks.
When you’ve seen enough, click Exit on the remote control to return to the slideshow editor.

You can continue to make adjustments to the slideshow until you have it just the way you want.
If the volume of the soundtrack sounded too loud or too soft, drag the “Slideshow volume” slider, shown above, to adjust the volume.

13. Click the Return button in the slideshow editor to exit the slideshow editor and return to the main menu.

14. Choose File > Save Project to save your work.

Adding Photos and Files That Viewers Can Copy:

If you want viewers to be able to download images and other files from your DVD, you can add copies of the files to the DVD-ROM portion of the DVD.

Here are some ways to add files to the DVD-ROM contents:

  • In the slideshow editor, click Settings and then select “Add image files to DVD-ROM.”
  • Choose Advanced > Edit DVD-ROM Contents and drag the files to the DVD-ROM Contents window.

For more information about the DVD-ROM contents, see iDVD Help.

Add Images to the Background:

You can place images, groups of images, and movies in the menu background by dragging them into drop zones, which are numbered and labeled on each theme.

A drop zone is not a button that lets viewers play a slideshow or movie; it just provides an area where you can place media that adds interest to the menu background.

In the Fish One menu, the picture frame contains a drop zone.

You can fill the frame with a still image, with a video that plays repeatedly, or a short sequence of images that plays like a slideshow.

To add a slideshow to the drop zone:

1. Click the Media button and then click Photos at the top of the Media pane.

2. Drag a photo album or folder of pictures from the photos list to the drop zone in the menu.

  • Place the pointer directly over the drop zone text until you see the dotted lines appear, then release the mouse button.
  • To select multiple pictures in the list, press the Command key (it has the Apple logo on it) and click the pictures you want. Then release the Command key and drag the pictures to the drop zone.

Tip: You can drag the image in the drop zone to reposition it.

3. Click the first image that appears in the drop zone.

The Photos pane, shown below, appears above the image you clicked. You can use the Photos pane to make adjustments to the slideshow.

4. Drag the slider in the Photos pane to view the images in the drop zone.
If you want to change the order in which they appear, click Edit Order to open the drop zone photo editor, shown below.
5. Drag the images into the order in which you want them to appear and delete any you don’t want to keep.
You can also drag other images to the drop zone photo editor.

6. Click the Return button when you’re finished.

Note: You can add a short movie or a single still image to a drop zone instead of a slideshow. If you add a short movie, it plays repeatedly in the drop zone; if you add a still image, the image fills the drop zone.

7. Click the Preview button to see the images play.
The images will “loop,” or keep playing continuously, so click the Exit button on the DVD remote control when you’ve seen enough.

8. Choose File > Save to save your work.

Add Transitions:

With all this content and good-looking menus, it would be great to have transitions to smooth the movement from the menu to your movie and slideshow when the viewer clicks a button on the menu.

To set transitions for the main menu:

1. Click one of the buttons on the menu to select it, then choose Edit > Select All Buttons.
2. Click Buttons to open the Buttons pane.
3. Choose Push from the Transition pop-up menu, shown below.


4. Click one of the arrow buttons next to the Transition pop-up menu to set the direction you want the transition to move.

Note: You can only click the arrow buttons for transitions that allow you to set the direction of the transition.

5. Click the Preview button and use the DVD remote control to select the menu buttons one by one and view the results.
When you’re done, click Exit on the DVD remote control.

6. Choose File > Save to save your project.

Editing in the DVD Map:

The DVD map gives you an overview of your whole project and lets you quickly apply changes to more than one item at a time.

You can look at it as batch editing. Here are some of the things you can do in the DVD map:

  • Customize the menu settings for one menu or multiple menus at once.
  • Add slideshows, movies, or menus directly to your project.
  • Delete one or more objects from your project at once.
  • See and change transitions from menus to other menus, movies, or slideshows.
  • Double-click a slideshow icon to open the slideshow editor.
  • Double-click a movie icon to play the movie.
  • Click once to select an icon, then use menu commands to apply a change to it.
  • Drag to select more than one icon, then use menu commands to apply a change to all the selected items.