Editing

Cropping video clips:

Cropping allows you to edit a clip by keeping only the portion of video you like and removing the rest.

It’s a good idea to crop your clips before dragging them out of the Clips pane and into your movie. However, you can also crop a clip after you’ve added it to your movie by selecting it in the clip viewer or timeline viewer.

To crop a clip:

  1. Select the clip you want to crop by clicking it in the Clips pane, clip viewer, or timeline viewer.
  2. Drag the playhead (A, shown above) to where you want your scene to begin.
  3. Place your pointer (B, shown above) just below the playhead, and then drag to the right to include the footage you want to keep. The gold portion of the scrubber bar (shown below) highlights the footage you’ve selected.
  4. To precisely adjust where the selected footage begins and ends, click a crop marker (shown below) to select it, and then press the Left or Right Arrow key to move the crop marker one frame at a time. To move the marker in ten-frame increments, hold down the Shift key while pressing the arrow key. You can see the duration of your selected footage in minutes:seconds:frames at the bottom edge of the iMovie window.
  5. Choose Edit > Crop to keep the portion of video you’ve highlighted and remove the rest.

If you want to trim away only the beginning or end of a clip, drag the crop markers to highlight the portion you want to remove, and then choose Edit > Clear.

When cropping, keep in mind that iMovie HD only hides the footage you don’t want to show and doesn’t actually remove or delete it. If you trim away too much, you can always choose Edit > Undo to cancel your change, or extend the clip back to the desired length by dragging one of its edges in the timeline viewer.

Adding a web link to your movie:

If you intend to publish your movie to the Internet as a video podcast or share it as a QuickTime movie, you can add web links to it. When your movie is played, the web link appears and viewers can click the link to open the webpage in a separate browser window.

You add a web link to your movie as part of a chapter marker. The web link appears over that section of your movie.

To add a web link to your movie:

  1. Move the playhead to the point at which you want to display the web link. The web link will be displayed in your movie for 8 seconds; therefore, it’s a good idea not to add a web link any later than 8 seconds before the end of the movie. It’s also a good idea not to add a web link within a transition. If you do so, it may be difficult to see. Because a web link appears as dark blue text in a QuickTime movie, add it to a piece of video with contrasting color so the link is easy to see.
  2. Click the Chapters button, and then click Add Marker. To quickly add a chapter marker, you can also choose Markers > Add Chapter Marker.
  3. Type a chapter title next to the thumbnail that appears in the Chapters pane.
  4. Double-click Link URL below the chapter title and type the web address. (If you don’t see Link URL below the chapter title, choose Markers > Show Podcast URLs.) Be sure to include the full URL, including “http://” or other required parts of the address. If you don’t include the full address, your recipient may not be able to click the link to go to the website.

Chapter markers appear in the timeline viewer as yellow diamonds.

Note: You won’t be able to see the web link when previewing your movie in iMovie HD. Web links appear only after you export your movie as a podcast or QuickTime movie.

To remove a chapter marker and its web link, select the chapter marker in the timeline viewer, and then choose Markers > Delete Chapter Marker. (You can also select the chapter marker in the Chapters pane, and then click Remove Marker.) If you only delete the URL in the Chapters pane, the marker behaves as an ordinary chapter marker.

IMPORTANT: Web links you add to your movie do not appear in iDVD. When sharing your movie to iDVD, the places you added web links are treated as ordinary chapter markers. If you don’t want a web link to appear as a chapter marker in iDVD, you can delete the chapter marker in iMovie before exporting your project to iDVD, or you can delete the chapter menu item using iDVD.

Using theme elements in your movie:

You can choose from a collection of titles and visual effects to combine your video and photos with stunning backgrounds and animated graphics called “themes.” Use themes to add Hollywood-style polish to your movie and give it a creative and unified design.

IMPORTANT: To use themes in your movie, you must be using Mac OS X version 10.4.4 or later.

To use a theme element in your movie:

  • Click the Themes button.
  • Choose a theme from the pop-up menu at the top of the Themes pane.
  • Select a theme element that you want to use in your movie from the Theme Elements area. The Drop Zones window opens, and the theme previews in the iMovie monitor.

If the theme you chose contains titles, type your title in the Title field. (Some themes have multiple title fields.)

Do one or both of the following:

  • To add video clips to the theme, click the Clips button and drag video clips to the drop zones in the Drop Zones window.
  • To add photos to the theme, click the Media button, click Photos at the top of the media pane, and then drag photos to the drop zones in the Drop Zones window.
  • To remove an item from a drop zone, click the drop zone to select it, and then press the Delete key or drag it out of the drop zone.
  • Click the Themes button to return to the Themes pane.
  • Click Apply. The new clip is added to the end of your movie. A red progress bar indicates that the theme is rendering.
  • After the clip has finished rendering, drag it to where you want it to appear in your movie.



Tip:
After you’ve created a theme, you can also add it to your movie by dragging it directly from the Themes pane.

After you’ve added a theme element to your movie, you can change its duration by dragging one of its edges in the timeline viewer. You can also apply transitions and effects to it, as you would with any video clip. To remove a theme from your movie, select its clip in the clip viewer or timeline viewer, and then press the Delete key.

Changing an existing video effect:

You can make changes to a video effect that has already been rendered.

To change an effect:

  1. Select the clip that contains the effect you want to change in the clip viewer or timeline viewer. If you need to make the same change to more than one clip, select all the clips and update them all at once to save some time. For information about selecting multiple clips, see Related Topics below.
  2. Press the Delete key to remove the effect.
  3. Click the Editing button, and then click Video FX at the top of the Editing pane.
  4. Set your new effect settings.
  5. Click Apply.

Adding slow motion or speeding up a clip

If you want a clip or part of your movie to play in slow or fast motion, you can add the Fast/Slow/Reverse effect to it and set how fast you want your selected footage to play.

To learn how to add this effect, see “Using special effects to add visual interest” below.

Using special effects to add visual interest

You can add interesting effects to your movies to lend them special appeal, focus, or a sense of fun. iMovie HD offers a range of video effects that can make clips shake as if during an earthquake, fling sparkling fairy dust across the screen, filter a scene with passing fog, or add a streak of electricity to an image. Other effects change the brightness or contrast of the video, add slow motion, change colors, soften the focus, and more.

To apply a video effect to a clip:

  1. Select the clip or clips you want to alter in the clip viewer or timeline viewer. To apply an effect to a section of a clip or stretch it across a portion of multiple clips, drag the crop markers to select the frame range you want. For more information, see “Selecting part of a video clip” below.
  2. Click the Editing button, and then click Video FX at the top of the Editing pane.
  3. Select the video effect you want from the effects list. You see a preview of the effect in the iMovie monitor.
  4. Move the Effect In and Effect Out sliders to indicate when you want the effect to begin and end. When you drag the Effect In or Effect Out sliders, you see the times change next to the sliders. You can also click these numbers and type new times.
  5. Adjust the effect with any other available sliders. (Some effects have more options.)
  6. You can set the origination point for some effects. If you see a position indicator in the iMovie monitor, drag it to a location in the monitor where you want the effect to begin.
  7. Click Apply.

A red progress bar indicates when the effect has finished rendering.

To see how an effect looks in the clip or timeline viewer, move the playhead to a point in the movie before the effect (with no clip selected) and click the Play button.

After you’ve added an effect to your movie, you can select the effect’s clip or clips to play it, change it, or delete it at any time. You can also layer multiple effects over the same clip by repeating the steps above.

Tip: Some effects allow you to set the point where the effect originates. To see if this setting is available for an effect, position your pointer over the iMovie monitor. If the pointer changes to a crosshair, you can click in the monitor where you want the effect to start.

Adding a dissolve or other transition between clips:

You can add transitions between clips to smooth or blend the change from one scene to another. You can have clips fade in or out, dissolve into another clip, push one scene aside as the new scene enters, and so on.

Tip: When you add a transition to your movie, it may blur or hide some footage that you want viewers to see. Therefore, it’s a good idea to add extra time to the end or beginning of clips that you plan to add transitions to. (The amount of footage in a clip that’s used up by a transition equals about half the length of the transition.) To adjust the length of your clips, see “Fine-tuning where a clip begins and ends.”

To add a transition between clips:

  1. Drag the playhead near the location where you plan to add the transition.
  2. Click the Editing button, and then click Transitions at the top of the Editing pane.
  3. Click a transition style in the transitions list to select it. You see a preview of the transition in the iMovie monitor.
  4. Set the duration of the transition using the Speed slider.
  5. If necessary, set a direction for the transition using the arrow buttons.
  6. To add the transition to your movie, drag it from the transitions list to the clip viewer or timeline viewer.

When you drag the transition between the two clips you want joined, iMovie automatically makes room for it. (Fade and Wash effects are the only transitions that can be added to the beginning or end of a movie.) A red progress bar indicates when the transition has finished rendering.

To see how a transition looks in the clip or timeline viewer, move the playhead to a point in the movie before the transition (with no clip selected) and click the Play button.

After you’ve added a transition to your movie, you can select the transition’s clip to play it, change it, or delete it at any time. For more information, see Related Topics below.

Tip: You can change multiple transitions in a movie with a single procedure. Just select the clips you want (or all the clips in the movie), set up the transition options you want, and click Update. To select all your transitions at once, select a single transition and then choose Edit > Select Similar Clips.

Adding titles or text:

With iMovie HD, you can add a variety of text to your movie, including film titles, credits, subtitles, and much more. You can also select a font and color for your text and chose how you want it to move on and off screen.

Tip: When creating a title, be sure its duration isn’t longer than the duration of the video clip or color clip that it appears over. You can place a short title sequence on a longer clip, but you can’t place a long title sequence on a short clip.

IMPORTANT: To add titles to a clip that contains a transition, remove the transition first, and then add your text and reapply the transition.

To create a title for a clip:

  1. Click the Editing button, and then click Titles at the top of the Editing pane.
  2. Select a title style from the titles list. You see a preview of the title in the iMovie monitor.
  3. If necessary, set a direction for the title using the arrow buttons.
  4. Type the text you want in the text fields. Some title styles include Add (+) or Delete (-) buttons so you can add or delete lines of text.
  5. To change the color of the text, click the Color box to select a color.
  6. Choose a font style from the Family and TypeFace pop-up menus, and drag the size slider to change text size.
  7. Drag the speed slider and pause slider to change the duration of the title. The title’s total duration is the sum of the speed and the pause durations, shown at the bottom of the Titles pane.
  8. If you want the title to appear over a black background, select the “Over black” checkbox.
  9. You can set the origination point of some title styles. If you see a position indicator in the iMovie monitor, drag it to a location in the monitor where you want the title to begin.

To add the title to your movie, do one of the following:

  • To have your title appear over black, make sure you selected the “Over black” checkbox in step 8 above, and drag the title from the titles list to where you want it to appear in the clip viewer or timeline viewer.
  • To have the title start over the beginning of a clip, make sure you did not select the “Over black” checkbox in step 8 above, and drag the title from the titles list to the left of the clip you want to play underneath the title.
  • To have the title start in the middle of a clip, move the playhead to where you want the title to start, and then click the Add button at the bottom of the Titles pane. (Because iMovie titles can only start at the beginning of a clip, iMovie creates a new clip at the spot where you want your title to begin by splitting the existing clip in two.)

If the title you created is shorter than the video clip you added it to, iMovie splits the clip in two, and the first of the two resulting clips contains the title. If the title is longer than the clip, the title automatically extends across the next clip or clips in your movie. If this is the case, the final clip on which the title appears will be split where the title ends.

After you add a title to your movie, you can change or remove it at any time. For more information, see Related Topics below.

Adding special characters and symbols to your text:

You can insert special characters, such as mathematical symbols, letters with accent marks, or arrows and other “dingbats,” into your titles using the Character Palette. You can also use this palette to enter characters from other languages.

To insert special characters and symbols:

  1. In the Titles pane, click in a text field where you want the special character or symbol to appear.
  2. Choose Edit > Special Characters.
  3. Choose the type of characters you want to see from the View pop-up menu at the top of the Character Palette. If you don’t see the View pop-up menu, click the button in the upper-right corner of the Character Palette to show the top portion of the window.
  4. Click an item in the list on the left to see the characters that are available in each category.
  5. Select the character or symbol in the right column that you want to insert into your document, and then click Insert. To see more options for each character, such as the variations in glyphs for some characters, click the Character Info triangle or Font Variation triangle at the bottom of the Character Palette.

If the character doesn’t appear in your title, iMovie may not support that character.

Mix video formats within a project:

You’ll get best results from iMovie if you use the same video format for all of the footage in a project. If you don’t have this option, then these steps may allow you to mix various media footage (DV, HDV, MPEG-4) in the same project using iMovie HD.
Normally, when you attempt to import footage from a different camera type than what’s used in your current iMovie project (iSight footage is the exception—you can import it into any project format), iMovie won’t let you and may give you the following warning message:

“The attached camera uses a different video format than your project’s format. To use this camera, disconnect any other tape-based cameras, then create a new, empty project.”
Don’t worry; it can be done.

If you need to mix footage from different camera types, follow these steps:

  1. Import the additional footage into a new iMovie project.
  2. Select the imported footage in the clips pane or timeline and copy the clips to the clipboard (from the Edit menu, choose Copy).
  3. Close the project and open the project in which you want the clips to appear.
  4. Paste the clips into the clips pane or timeline (from the Edit menu, choose Paste).

iMovie HD will automatically convert the footage so that it can be used in this project. Please be aware that depending on the project and footage formats, the footage may be converted to a lower quality.

If your footage is of a different aspect ratio, it may be letterboxed or pillarboxed to fit the project you are pasting into. If you need to add an effect to such footage, consider adding the effect in the clip’s original project before cutting and pasting it into the new project.

What are Letterboxing, Pillarboxing and Windowboxing?

When the proportions of an image don’t exactly match the proportions of the screen where the image is displayed, you might see black bars in the empty space of the screen. Depending on where the black bars are placed, this is referred to as letterboxing, pillarboxing, or in some cases what is informally known as “windowboxing”. These terms are explained below.

Letterboxing: Black bars at bottom and top of screen.

A letterbox is usually seen when widescreen content is displayed on a standard size screen. You might see this for example if you view a widescreen DVD movie where the image dimensions are wider than would fit your television or display.

You might also see this if you import widescreen footage into a standard (4:3) iMovie project, or when viewing photos in iPhoto that are landscape orientation.

Pillarboxing: Black bars at left and right of screen.

A pillarbox is usually seen when standard dimension content is displayed on a wide screen. You might see this for example when watching an older TV show on a widescreen HDTV, or Cinema Display.

You might also see this if you import standard DV footage (4:3) into a widescreen (16:9) iMovie project, or when viewing photos in iPhoto that are portrait orientation.

Windowboxing: Black bars on top, bottom, left, and right of image.

A windowbox is usually seen when widescreen content was manually letterboxed for standard size screen (4:3), but then viewed on a widescreen display. You might see this for example when watching a commercial for an upcoming film, or an older music video on a widescreen HDTV or Cinema Display.

You might also see this if you import footage that was manually letterboxed into an iMovie project. You can tell if the footage has a letterbox effect already applied by viewing the footage in QuickTime Player.

Deleting or editing Gallery content:

If you select a project from the iMovie Project Library, then choose File > Move Project to Trash and click Delete, only the locally stored project is deleted. The movie is still online at MobileMe. The online copy of the movie can be removed from MobileMe Gallery by clicking the Delete icon in the MobileMe toolbar. Another way to remove movies from MobileMe is to choose Share > Remove from MobileMe in iMovie. This removes both the locally stored movie and the published project.

Tips to improve performance:

Only render one clip at a time:

Rendering clips takes a lot of processing power. If iMovie seems unresponsive, consider waiting until a clip is finished rendering before continuing or rendering another clip. You could also render clips in small batches to improve responsiveness.

Change playback quality:

If you are using iMovie 4 or later, consider changing the playback quality setting in iMovie preferences.

Note: If you are using an older computer, try turning off the option “Keep playhead centered during playback” in the playback pane of iMovie preferences by following these steps:

  1. In iMovie choose iMovie>Preferences.
  2. Select the playback pane.
  3. Deselect the “Keep playhead centered during playback” checkbox.


Turn off Audio Waveforms:

If you are using iMovie HD 5 or later, consider turning off “Show Audio Waveforms” from the View menu to free up processing power.

Don’t store your project in a folder that uses FileVault:

If you are using Mac OS X 10.3 or later, make sure the project you are working on isn’t saved in a folder that’s protected by FileVault.

Quit unused applications and users:

Quit any open applications you’re not using. If Fast User Switching is on, consider logging out other users.

Check the disk:

Open Disk First Aid. Check the startup disk, and the disk where the project is saved.
Use Disk Utility to Repair Permissions on the startup disk.

Check for plug-ins:

Check to see if there are any plug-ins in this directory: ~/Library/iMovie/. If so, remove them. Reopen iMovie and see if performance is improved. If this resolves the issue, contact the plug-in’s developer for more information.

Check also for non-Apple plug-ins in /Library/QuickTime/ and ~/Library/QuickTime/ . Try moving any non-Apple items out of this folder and relaunch iMovie. Some older third party QuickTime plug-ins may interfere with iMovie operation. If this resolves the issue, check with the plug-in manufacturer to see if an update to the plug-in is available.

Copy the project to the computer’s hard disk:

If your project is saved on an external hard drive, try copying the project folder to the computer’s hard disk (if there is room) and open it from there. See if this improves performance.

Rebuild the project:

If you are only experiencing the issue in one project, consider rebuilding it.

Defragment the disk:

If you have access to a disk defragmenting utility, consider defragmenting the drive where the project is located.

Project length:

  • If you are only experiencing the issue in one project, consider rebuilding it.
  • The longer and more complicated the project, the more RAM, disk space and processor power the project may require. Try splitting lengthy projects into multiple shorter projects if you are using an older Macintosh and notice a degredation in performance with lengthy projects.
  • Using other suggestions in this article (such as changing the playback quality setting) may also make a difference without having to limit your project length.

Working with HD footage:

High Definition footage (HDV 720p or 1080i) requires extra CPU performance to play and edit. Make sure your computer meets the system requirements for HD editing ( 1 GHz G4 or faster) if you are attempting to work with HD footage.

Related document:

303529: iMovie: How to move clips from one project to another
42964: iMovie: “Disk Responded Slowly” Alert

Improving audio and video synchronization:

If your audio and video do not play in sync when exported to QuickTime or iDVD, check the following:

  1. Make sure the DV camera you used to record or capture the footage was set to 16-bit at the time of recording (not 12-bit).
  2. Make sure your QuickTime software is up to date.
  3. If you are using iMovie 3, make sure you have updated to iMovie 3.0.3 or later.

You may be able to resolve audio synchronization issues by extracting the audio from the video clips in the iMovie project to a separate audio track:

  • Select all video clips in the timeline (from the Edit menu, choose Select All).
  • Extract audio to a separate track (from the Advanced menu, choose Extract Audio).

Export this project to QuickTime and see if your audio remains in sync when the resulting file is viewed in QuickTime Player.

Related documents:

61636: iMovie: Use 16-bit audio for best results

Undoing your changes:

If you make a mistake or don’t like the changes you’ve made, you can undo them.

WARNING: After you save your project or empty the iMovie Trash, you cannot undo any of the changes you made to your project before that time.

Here are ways to undo your changes:

Choose Edit > Undo to remove your last change. Continue choosing Undo to cancel your previous changes one by one.
Choose Advanced > “Revert Clip to Orginal” to undo all of the changes made to a selected clip.
Choose File > “Revert to Saved” to undo all of the changes made to a project since the last time you saved it.

After you undo a change, you can choose Edit > Redo to reimplement the change.