Customizing

Using analog/FireWire converter devices with iMovie:

You can convert video in 8 mm, Hi8, VHS, or SVHS format to digital video (DV) format, using a special converter box (sometimes referred to as AV adapters), such as the Sony DVMC-DA2 or the Synchrotech Formac Studio.
If you use a converter to import non-DV video, you can’t control your camera or deck with iMovie. However, you can manually control the camera to import video clips and use all of iMovie’s editing features, then export your video through the converter back to your video recorder or camera.

A converter of this kind will generally have standard S-video and RCA input/output ports for video and audio, and a FireWire or iLink (IEEE 1394) input/output port. Make sure you have the appropriate cables for your configuration.

To ensure compatibility with third-party video devices, check the iLife Camcorder Compatibility page, the Apple Store, and/or vendor websites for compatibility information.

For more information, check the documentation that came with your converter.

Capturing Analog Video From a Converter Box Into iMovie:

Follow these steps to import video from an analog-to-FireWire converter device.
While this specific order may not be necessary with all converters, it will help ensure proper initialization between the hardware and software:

  1. Start up your computer, turn on the converter box, and connect the computer to the converter with a FireWire cable.
  2. Connect the video cable from the video output of the video source (for example, a VCR or video camera) to the analog video input of the converter box. A video camera should be in playback or VTR mode. Connect the audio source, too.
  3. The converter box will typically have a switch or button that tells the device which direction to convert the video, analog to DV or DV to analog. For capturing analog video, you will want to press the button labeled “Analog In” or something similar.
  4. Connect a 4-to-6 pin FireWire cable from the DV out port on the converter box (sometimes labeled FireWire, IEEE 1394, or iLink with Sony devices) to a FireWire port on the computer.
  5. Open the iMovie application program.
  6. Make sure the Mode Switch under the iMovie monitor is set to Camera Mode, as shown here:
  7. Some converter boxes have a green status light, to indicate a good connection. If this light is amber or red at this point, try turning the device off for several seconds and then back on again. You may also try quitting and opening iMovie again.
  8. Press play on the VCR or analog camera. You should see the video signal in the iMovie monitor. If you have speakers or headphones connected to the VCR you can monitor the audio.
  9. Use the controls on the video source to manually cue the video tape to the desired spot, and click Import in iMovie. iMovie will create a new clip for about every nine minutes of video. You can join all the clips later by dragging them into the timeline.

Sending Video From iMovie to the Converter Box:

Follow these steps to export video to an analog-to-FireWire converter box.
While this specific order may not be necessary with all converters, it will help ensure proper initialization between the hardware and software:

  1. Start up your computer, turn on the converter box, and connect the computer to the converter with a FireWire cable.
  2. Connect the video cable from the video output of the source (for example, a VCR or video camera) to the analog video input of the converter box. A video camera should be in playback or VTR mode. Connect the audio source, too.
  3. The converter box will typically have a switch or button which tells the device which direction to convert the video, analog to DV or DV to analog. For exporting analog video, you will want to press the button labeled “Analog In” or something similar.
  4. Connect a 4-to-6 pin FireWire cable from the DV out port on the converter box (sometimes labeled FireWire, IEEE 1394, or iLink with Sony devices) to a FireWire port on the computer.
  5. Open the iMovie application program.
  6. From the iMovie menu, choose Preferences (or File menu in Mac OS 9).
  7. Click the Advanced tab.
  8. Make sure the checkbox for “Video Play Through to Camera” is selected.
  9. Choose Export Movie from the File menu, or press Command-E on the keyboard.
  10. In the Export Movie window, select the pop-up menu for “Export to Camera”, even if you’re exporting to a VCR through the converter.
  11. Press record on the VCR and click Export in iMovie.
  12. When finished, press the stop button on the VCR and Stop in the iMovie monitor.

Preparing a movie created in iMovie HD to work with iDVD:

If you’ve created a movie using iMovie HD, you can export the movie from iMovie HD directly to an iDVD project. Using iMovie HD, you can also export your movie as a QuickTime movie for later use in an iDVD project.

Here are ways to prepare your iMovie for iDVD:

  • To export your iMovie directly to an iDVD project, within iMovie HD choose Share > iDVD. The iDVD application opens, with your project in the iDVD window. If you’ve added chapter markers to your iMovie, iDVD uses them to create a scene selection menu automatically.
  • When iDVD opens, it selects a default theme, which appears in the iDVD window. If the iMovie you shared has chapter markers, you see two buttons on the iDVD menu, one that says “Play Movie” and another that says “Scene Selection.” If the movie does not have chapter markers, you see one button with the name of the movie you added. From here, you can begin editing your iDVD project, including selecting a different theme if you want.
  • To save your iMovie as a QuickTime movie that you can import into an iDVD project later, choose File > Export in iMovie HD. Click QuickTime, choose Full Quality from the pop-up menu, and then click Share.

Your movie is saved as a QuickTime movie in your Movies folder, making it available in the Media pane of iDVD. The movie is self-contained (it includes all the source files). Chapter markers are not preserved, so iDVD cannot create a scene selection menu for a QuickTime movie.

Important: If you add an iMovie HD movie with chapter markers to your iDVD project, be sure that all chapter markers are placed at least two seconds before or after a transition. (You should verify this in iMovie HD before adding the movie to your project in iDVD.) Otherwise, when you use the movie in an iDVD project, you may get an error message that says, “Burning Complete, errors were found during burning process” when you try to burn the project to disc. You will be unable to burn a disc until you fix the problem.


Using iMovie with NetBoot or a network user account:

Apple does not recommend using any version of iMovie in a NetBoot environment or when logged in as a user whose home directory is stored on a remote server. iMovie requires reliable data transfer at a high rate, and network latency issues can interfere with it.

Resolution:

You could try the server-based user account (but not NetBoot) if you configured iMovie to store project data on a local volume such as /Users/Shared. However, Apple will not provide technical support for this configuration.

The best solution is to create local accounts for using iMovie, managed via preference settings in Workgroup Manager. To learn more about managed preferences for local users, see page 101 of the Mac OS X Server User Management Guide For Version 10.3.3 or later.

Copying your movie back to tape:

You can record your movie onto a tape in your camera. The time it takes to copy a standard definition movie back to tape is equal to the length of the movie.

IMPORTANT: If you are copying a high definition movie to tape, the recording time can take considerably longer than the length of the movie. iMovie HD must perform steps to encode and perform an audio mixdown before it can copy the data to tape.

If you plan to transfer your movie from tape to a videocassette or a DVD that will be played on a VCR or DVD player that uses another format (such as PAL in Europe or NTSC in North America and Japan), see “Exporting your movie for viewing in PAL or NTSC format” below.

To copy your movie back to tape:

  1. Set your camera to VTR mode (some cameras call this VCR or Play mode) and insert a blank tape. (The tape must be at least as long as your movie.)
  2. Connect your camera to your computer using a FireWire cable.
  3. Choose Share > Video Camera.
  4. Set the number of seconds of black you want to begin and end the movie.
  5. Click the “Share selected clips only” checkbox if you only want to share clips you selected.
  6. Click Share.

If you have trouble recording back to your camera, check to see if your tape is write-protected. Or, you may have a PAL device that has FireWire input disabled. Contact the device manufacturer for more information.

Using Bluetooth wireless technology to share movies:

You can use Bluetooth wireless technology to transfer movies wirelessly to other computers, mobile phones, personal digital assistants, and more. To send a movie to a Bluetooth device from iMovie HD, the device must be compliant with the Third Generation Partnership Program (3GPP) and have an appropriate video application that can display movies.

To set up your Bluetooth device, use Bluetooth Setup Assistant, located in /Applications/Utilities. For more information about Bluetooth technology, choose Help > Mac Help in the Finder, and search for Bluetooth.

  1. Choose Share > Bluetooth.
  2. If you only want to send clips you selected in the timeline viewer or clip viewer, select the “Share selected clips only” checkbox. Don’t select this box if you want to send the whole movie.
  3. Click Share to compress the movie.
  4. Choose the type of device from the Device Type pop-up menu and a category of device from the Device Category pop-up menu.
  5. Click Search if you want to search for available Bluetooth devices.
  6. Click a device in the Device window, and then click Select.

To view your movie on a Bluetooth device, check the documentation that came with the device. Usually there is a way to choose the file from a menu, which will then automatically open the video application and play the movie.

For more information about Bluetooth technology, visit Apple’s Bluetooth website.

Sending your movie as an email attachment:

You can email a compressed, QuickTime version of your movie to family and friends.

To send your movie as an email attachment:

  1. Choose Share > Email.
  2. Choose the email application you want to use from the pop-up menu.
  3. If you want, type a new name for the movie you’re sending.
  4. If you only want to share clips you selected, click the “Share selected clips only” checkbox.
  5. Click Share. iMovie opens a New Message window in your email application with the QuickTime movie attached.
  6. Enter an address, a subject line, and the text of the message, then click Send.

IMPORTANT: If you send a movie that has a large file size, it will take longer for people to download it. It’s a good idea to limit the size of the movie you send.

Saving your movie as a QuickTime movie:

When you save your movie in QuickTime format, you can play it on computers or publish it on a webpage, a CD, or your iDisk.

When you export your movie to QuickTime, you can choose one of these settings:

  • Email: Best for sending over email.
  • Web: Best for playing on the web.
  • Web Streaming: Best for posting on a QuickTime streaming web server.
  • CD-ROM: Best for playback from CD-ROM drives.
  • Full Quality: Creates a movie with original quality, preserving the most data possible. Use for movies you want to import into other applications, such as iDVD, DVD Studio Pro, or Final Cut Pro, for further editing.
  • Expert Settings: Use when you want to customize your export or use other formats and codecs.

Important: The viewer needs QuickTime 7 or later to watch your QuickTime movie.

To save your movie as a QuickTime movie:

  1. Choose Share > QuickTime.
  2. Choose a movie format from the pop-up menu.
  3. Click the “Share selected clips only” checkbox if you only want to share clips you selected.
  4. Click Share.
  5. Name your movie, select a location for the file, and click Save.

The time it takes to save the movie depends on the movie’s length and the format you choose.

Adjusting the playback quality of your movie:

iMovie HD automatically displays your movie at high quality if the speed of your computer processor allows. As a rule, you shouldn’t adjust the playback quality unless you are experiencing problems with playing your movie.

When adjusting playback quality, you can choose one of three settings: Standard, High, or Highest. You may want to display your project in iMovie HD at highest quality if you have a fast hard disk, an upgraded video card, or a very simple project. You may want to choose standard quality if you have a very complex project that skips or stutters when you play it.

To adjust the playback quality of your movie:

  1. Choose iMovie HD > Preferences.
  2. Click Playback.
  3. Select Standard, High, or Highest.

Note: Adjusting the playback quality doesn’t affect the quality of your stored movie or your shared movie; these are always at high quality.

Using a TV monitor with iMovie HD:

You can direct iMovie HD to play your movie on a TV monitor connected to your computer to see how it will look. You can edit on the TV screen and preview your editing changes to see how video footage, titles, effects, and transitions will look. To connect a TV monitor to your computer, see the manual that came with your computer for requirements and connection instructions.

Note: You cannot use this feature with high definition video, MPEG-4, or iSight projects. Some operations, such as previewing effects, transitions, themes, and titles, will work more slowly when this feature is enabled.

To set iMovie HD to play a movie on a TV monitor connected to your computer:

  1. Choose iMovie HD > Preferences.
  2. Click Playback.
  3. Select the “Play DV project video through to DV camera.”

Using the preview controls:

Before you add a transition, title, effect, or theme element to your movie or the Ken Burns effect to a photo, you can use the preview controls to see how it will look.

To use the preview controls:

  • Click the Play button (A) to play and pause the preview.
  • Click the Loop button (B) to make the preview repeat automatically upon completion.
  • Drag the Preview playhead (C) to display a specific frame in the preview.
  • Click the Hide Preview button (D) to leave preview mode and display your movie in the iMovie monitor.
  • Click the Apply button (E) to add the transition, title, effect, theme element, or photo to your movie. (The item is added where the playhead is positioned in the clip or timeline viewer.)

Playing your movie so that it fills the whole computer screen:

To better see the details in your movie, you can play it so that it fills the whole computer screen. This is called “full-screen playback.”

To use full-screen playback:

  1. Click the Play Full Screen button (shown above).
  2. Click anywhere in the movie to stop it from playing and leave full-screen view.

Adjusting the playback quality of your movie:

iMovie HD automatically displays your movie at high quality if the speed of your computer processor allows. As a rule, you shouldn’t adjust the playback quality unless you are experiencing problems with playing your movie.

When adjusting playback quality, you can choose one of three settings: Standard, High, or Highest. You may want to display your project in iMovie HD at highest quality if you have a fast hard disk, an upgraded video card, or a very simple project. You may want to choose standard quality if you have a very complex project that skips or stutters when you play it.

To adjust the playback quality of your movie:

  1. Choose iMovie HD > Preferences.
  2. Click Playback.
  3. Select Standard, High, or Highest.

Note: Adjusting the playback quality doesn’t affect the quality of your stored movie or your shared movie; these are always at high quality.

Showing more detail in the timeline viewer:

Depending on the length of a movie and its individual clips, it may be difficult to edit if the clips appear too small or too large in the timeline viewer. If a clip icon is too large, it may be difficult to reposition; if it’s too small, it may be difficult to select, edit, and move accurately. You can adjust the size of clips in the timeline viewer, making them larger or smaller when needed.

To adjust the size of clips in the timeline viewer:

  1. Click the Timeline Viewer button (shown above).
  2. Drag the size slider.

Removing transitions, titles, and effects:

You can easily remove any transition, title, or effect that you’ve added to your movie.

To remove a transition, title, or effect, do one of the following:

  • To remove a title or effect, select the clip or clips that contain the title or effect you want to remove in the clip viewer or timeline viewer.
  • To remove a transition, select the transition’s icon (shown above) in the clip viewer or timeline viewer.
  • If you want to select all your transitions at once, select a transition and choose Edit > Select Similar Clips.
  • Press the Delete key.

Note: When you remove a title or effect from a clip, you restore the clip to how it looked before you added the title or effect. If a clip was split in two when you added the title to it, iMovie merges the clips back together when the title is removed.